15 Mar

You can’t make an omelette without breaking a few eggs…

Things got a little complicated today. I bet you know the feeling when simple tasks escalate in time consuming issues, just like that, out of the blue. You try to find the solution, you find the solution, you follow the steps necessary to resolve the issue, you realize there’s a problem with completing one of the steps, you google for a solution, you find the solution, you follow the steps, and so on… until there’s some kind of stackoverflow exception. I got frustrated and today’s post is going to be all about complaining ;)

In the last couple of days I was going through the next chapters of App Development with Swift, the book I told you about in my first Swift for dummies post. I am determined to complete this beginners course to have a solid foundation for my future development. Things went well at first, but yesterday Xcode started complaining when I opened one of the playground files.

I thought maybe this was meant to be a joke, like

You know nothing, Jon Snow

They misspelled the first name, by the way ;) This one was actually easily fixable, I just had to remove the first argument label and the code became runnable. But it made me suspicious and soon I found out the reason for this inconsistency: my Xcode needs an update, my current version is 7.1.

Easy peasy lemon squeezy. So I opened App Store, searched for Xcode and clicked Update button:

Nothing really happened except that the waiting animation showed up in the top bar. So I waited. And waited. Got myself a coffee in my new birthday cup:

And waited.. In case somebody asks: yes, I did try to turn it off and on again :) Faced the same problem after restart, though. My next idea was to upgrade my OS to Sierra. I clicked the update button and waited for the download progress bar to reach its end (took time, it’s over 5 GB). In a meanwhile I googled for my Xcode upgrade problem and followed the steps described here. Resetting cache didn’t help so I went for the second option, which is downloading the archive directly from apple. Few minutes later a popup appeared saying that my Sierra failed to download and I have to try again. D’oh! I had more luck with downloading the Xcode archive, the file was successfully saved in my Downloads folder. I double clicked and… can I have drums, please?

Look at this:

cpio read error: Undefined error: 0

Really? I mean, Apple, really? This looks so lame ;) What to do, what to do? Oh, I know, maybe I’ll google for a solution for a change.

It looks I have to upgrade my system after all, so I’ve just made another try and..

Tadaaam! While I was writing this post the download process has finally succeeded and this beautiful screen has just popped out. I’m going to hit the Continue button now. I’ll let you know in my next entry how things went for me ;)